Is hServer community edition available for RedHat Linux only?

While downloading the community edition of hServer there is only a single option in the Operating systems. Can hServer be run on hadoop cluster running on Ubuntu?


We've initially targeted Redhat-based distributions of Linux (RHEL, CentOS, etc.) due to their prevalence in server configurations, but we're also actively investigating a native installation package for Debian-based distributions such as Ubuntu.

In the interim, if you'd like to use hServer on your Ubuntu system for testing and development purposes, you may do so through the use of the Alien utility. If you're not familiar with Alien, it is a common tool used to convert RPM packages to Debian packages. You can find more information about the use of Alien here:

Step-by-step instructions
  • Install the Alien utility and create the .deb package from the .rpm package:
    # apt-get install alien
    # alien -c -k soss-5.0.19-219.el5.x86_64.rpm
  • Prepare for installation (server installations only; remote client installations may proceed to Step 3)
    # apt-get install chkconfig
    # ln -s /usr/bin/service /sbin/service
  • Install the .deb package
    # dpkg -i soss-5.0.19-219.el5.x86_64.deb
Note: insserv may print warnings about the init files of other services, but that's normal and unrelated to the ScaleOut service.

The SOSS service (sossd) will start automatically.

If this answers your question, please mark this answer as accepted. Otherwise, please let us know in the comments if you have any issues.


New member
I tried this, but alien failed with
Unpacking of 'soss-5.0.19-219.el5.x86_64.rpm' failed at /usr/share/perl5/Alien/Package/ line 168.
I tried alien with some other rpms, it worked fine.


We've tested this method on Ubuntu 10.04 and 11.04. Which version of Ubuntu are you running? Did you run the commands under an elevated shell (or with sudo)?


We've just tested the process with a fresh Ubuntu 12.04 installation with success. Your system is likely misconfigured in some way which causes Alien to fail, such as a package implicitly required by the script.

Looking at line 168 of the Alien script, that step calls the rpm2cpio command and an automatically detected decompression utility. Please add the -v option to your Alien command for more details on which step is failing:

# alien -c -k -v soss-5.0.19-219.el5.x86_64.rpm